IZ0 - Sharpen Q Outbound Calling Incident

Incident Report for Sharpen

Resolved

This incident has been resolved.
Posted Jun 03, 2026 - 15:53 UTC

Monitoring

Outbound Dialing in SharpenQ has been resolved and we are continuing to monitor for stability.
Posted Jun 02, 2026 - 11:24 UTC

Investigating

We are aware of an incident preventing outbound calls from completeting in Sharpen Q. We are working with all avaiilable resources to resolve.
Posted Jun 02, 2026 - 11:20 UTC
This incident affected: Isolation Zone 0 (Sharpen Q, Outbound Voice).