IZ1 SharpenQ Incident

Incident Report for Sharpen

Resolved

We've continued to see platform stability/recovery improve since our engineering teams implemented a fix action. Outbound calling capabilities, queue performance, call quality, etc have all restored to baseline levels of functionality.

In the event that you're continuing to see impact with certain queues, end-users, or specific actions within the Sharpen application suite - please reach out to our Care Team via your existing support case.
Posted Jul 10, 2026 - 20:49 UTC

Monitoring

A fix has been implemented and we are observing Sharpen Q performance improvement for call quality and outbound call delays. We are continuing to monitor for ongoing stability.
Posted Jul 10, 2026 - 19:39 UTC

Identified

We believe we have identified the issue impacting SharpenQ performance in IZ1 and are implementing a fix.
Posted Jul 10, 2026 - 19:21 UTC

Investigating

We are currently aware of an issue in our IZ1 isolation zone affecting Sharpen Q performance, including delays in call connection, audio quality impact, and delays with Outbound Calls connecting. Our team is actively investigating and working toward a resolution.
Posted Jul 10, 2026 - 18:21 UTC
This incident affected: Isolation Zone 1 (Sharpen Q, Outbound Voice).