Sharpen Q slowness (IZ1)

Incident Report for Sharpen

Resolved

This incident has been resolved.
Posted Jun 17, 2025 - 17:18 UTC

Update

We are continuing to monitor recovery. We have seen recovery for for most organizations at this point, and are continuing to investigate remaining symptoms for those who are still experiencing impact.
Posted Jun 17, 2025 - 17:02 UTC

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Jun 17, 2025 - 15:54 UTC

Update

We have isolated the fault zone and are organizing next steps to correct the issue.
Posted Jun 17, 2025 - 15:34 UTC

Investigating

Users of the Sharpen Q platform in IZ (app.iz1.sharpen.cx) may be experiencing slowness, disrupting the successful execution of Sharpen Q functions. We have all necessary subject matter experts engaged to resolve the issue as soon as possible.
Posted Jun 17, 2025 - 15:19 UTC
This incident affected: Isolation Zone 1 (app.iz1.sharpen.cx, API, Sharpen Q).