Inbound calls intermittently receiving fast busy or unable to be picked up
Incident Report for Sharpen
Resolved
This incident has been resolved. We have identified root cause, confirmed full restoration of service was accomplished at 5:02 PM EDT, and are working through long term corrective actions to prevent this from occurring again.
Posted Sep 15, 2020 - 23:53 UTC
Monitoring
As previously noted, a fix has been implemented and we are continuing to monitor.
Posted Sep 15, 2020 - 22:54 UTC
Identified
We have identified the core issue, corrected the problem, and are monitoring all operations. We will continue to monitor and update as we conclude more.
Posted Sep 15, 2020 - 22:53 UTC
Monitoring
We have identified a failure point causing the intermittent fast busy for inbound calls. A fix was implemented at 5:05 PM EDT. We're now validating a full fix.

We are still investigating some intermittent reports of webRTC failures associated with no audio for those using Sharpen Q phone.
Posted Sep 15, 2020 - 21:57 UTC
Update
We are continuing to investigate while we observe many customers are experiencing recovery.
Posted Sep 15, 2020 - 21:27 UTC
Investigating
We are currently investigating this issue.
Posted Sep 15, 2020 - 21:09 UTC
This incident affected: Isolation Zone 0 (app.sharpencx.com, Sharpen Q, Inbound Voice, Chat, Email, Fax, SMS).