Inbound calls routed to Classic Logic on IZ1 saw dead silence starting around 5:42 PM ET. Our team traced this to a database performance issue affecting voice processing and had it fixed by 6:56 PM ET. Calls are back to normal now.
Posted Jul 22, 2026 - 23:10 UTC
Monitoring
We've identified the issue affecting inbound calls to Classic Logic on IZ1 and applied a fix. Calls should be working again, and we're continuing to monitor to confirm full stability.
Posted Jul 22, 2026 - 23:01 UTC
Investigating
We're currently investigating an issue affecting inbound calling in the IZ1 environment. Some customers may experience failed or dropped inbound calls during this time.
Our team is actively working to identify the root cause. We'll post an update as soon as we have more information.
Posted Jul 22, 2026 - 22:30 UTC
This incident affected: Isolation Zone 1 (app.iz1.sharpen.cx, Inbound Voice).