Sharpen Service Desk Unreachable

Incident Report for Sharpen

Resolved

This incident has been resolved with the resolution on the AWS outage at 6:53 PM Eastern Time. Our team has validated the restoration of this service.
Posted Oct 21, 2025 - 01:11 UTC

Investigating

Due to a outage with a cloud service provider, the Sharpen Service desk is experiencing reachability issues. The SharpenCare team is still reachable via phone or chat, however web tickets cannot be viewed or submitted. We are monitoring updates from our service provider for resolution.
Posted Oct 20, 2025 - 12:43 UTC
This incident affected: SharpenCare Service Desk (Service Desk Portal, Email Requests, Notifications).