We are continuing to investigate the issue. We're receiving additional reports of some users experiencing intermittent 504 Gateway timeout errors. We are including this symptom in our investigation as it likely shares the same root cause.
Posted Feb 19, 2026 - 22:18 UTC
Update
Thank you for your continued patience. We continue to aggressively address the intermittent service degradation impacting call connection times (agent-caller delay) and interface responsiveness. We will continue to pursue resolution as soon as possible.
Posted Feb 19, 2026 - 21:34 UTC
Update
We are continuing to investigate this issue.
Posted Feb 19, 2026 - 20:59 UTC
Update
We are continuing to investigate this issue.
Posted Feb 19, 2026 - 20:27 UTC
Update
Thank you for your continued patience. We are continuing to investigate the issue with all necessary resources involved. The problem is localized, but thus far our remediation efforts have not sufficiently remediated impact. We are continuing to explore all options to resolve the issue.
Posted Feb 19, 2026 - 19:57 UTC
Update
We are continuing to investigate this issue.
Posted Feb 19, 2026 - 19:25 UTC
Update
We are continuing to investigate this issue.
Posted Feb 19, 2026 - 18:55 UTC
Update
We are continuing to investigate the issue and have all necessary resources engage to resolve the issue as soon as possible.
Posted Feb 19, 2026 - 18:23 UTC
Investigating
We are currently investigating reports of degraded call quality affecting some customers, intermittently. The following behaviors have been reported beginning around 12:00 PM ET:
- Delays (up to 25+ seconds) between a call connecting and the interaction appearing in the agent interface - Dead air on inbound calls prior to ringing and after agent answer - Calls populating in queue but experiencing delays before being assigned to an agent - Absence of hold music for callers waiting in queue - Inability to place calls on hold
Our team is actively investigating the cause. We will provide an update as soon as additional information is available.
Affected: Voice interactions
Posted Feb 19, 2026 - 17:50 UTC
This incident affects: Isolation Zone 1 (Sharpen Q, Inbound Voice).