Call Connection Issues in IZ1

Incident Report for Sharpen

Resolved

The issue impacting inbound call handling in the IZ1 region has been fully resolved. Call traffic is operating normally, and no further disruptions are expected.
Thank you for your patience while we worked to restore service.
Posted May 30, 2025 - 20:03 UTC

Monitoring

Inbound call handling in the IZ1 region has recovered, and normal service has resumed. We are continuing to monitor the platform to ensure continued stability. No further impact is expected at this time.
Posted May 30, 2025 - 19:48 UTC

Identified

Initial efforts have led to a recovery in busy signals for inbound calls in the IZ1 region. However, a smaller percentage of calls may still experience intermittent delays when connecting. Our team is still diligently working to correct the issue.
Posted May 30, 2025 - 19:45 UTC

Investigating

We are currently investigating an issue impacting inbound call handling in the IZ1 region. Callers may experience intermittent delays connecting or experience a busy signal.
Posted May 30, 2025 - 19:25 UTC